CVE-2011-1764

NameCVE-2011-1764
DescriptionFormat string vulnerability in the dkim_exim_verify_finish function in src/dkim.c in Exim before 4.76 might allow remote attackers to execute arbitrary code or cause a denial of service (daemon crash) via format string specifiers in data used in DKIM logging, as demonstrated by an identity field containing a % (percent) character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2232-1
NVD severityhigh (attack range: remote)
Debian Bugs624670

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)wheezy4.80-7+deb7u3fixed
wheezy (security)4.80-7+deb7u5fixed
jessie (security), jessie4.84.2-2+deb8u4fixed
stretch (security), stretch4.89-2+deb9u2fixed
buster, sid4.90~RC3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.75-3high624670
exim4sourcelenny(not affected)
exim4sourcesqueeze4.72-6+squeeze1highDSA-2232-1

Notes

[lenny] - exim4 <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems