CVE-2011-1831

NameCVE-2011-1831
Descriptionutils/mount.ecryptfs_private.c in ecryptfs-utils before 90 does not properly check mountpoint permissions, which allows local users to effectively replace any directory with a new filesystem, and consequently gain privileges, via a mount system call.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2382-1
NVD severitymedium (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ecryptfs-utils (PTS)squeeze (security), squeeze83-4+squeeze1fixed
wheezy99-1fixed
sid, jessie103-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ecryptfs-utilssource(unstable)92-1medium
ecryptfs-utilssourcelenny68-1+lenny1mediumDSA-2382-1
ecryptfs-utilssourcesqueeze83-4+squeeze1mediumDSA-2382-1

Search for package or bug name: Reporting problems