CVE-2011-1841

NameCVE-2011-1841
DescriptionCross-site scripting (XSS) vulnerability in the link_to helper in Mojolicious before 1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2239-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmojolicious-perl (PTS)squeeze, squeeze (security)0.999926-1+squeeze2fixed
wheezy2.98+dfsg-2fixed
jessie, stretch, sid5.54+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmojolicious-perlsource(unstable)1.12-1medium
libmojolicious-perlsourcesqueeze0.999926-1+squeeze2mediumDSA-2239-1

Search for package or bug name: Reporting problems