CVE-2011-1843

NameCVE-2011-1843
DescriptionInteger overflow in conf.c in Tinyproxy before 1.8.3 might allow remote attackers to bypass intended access restrictions in opportunistic circumstances via a TCP connection, related to improper handling of invalid port numbers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs627503

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tinyproxy (PTS)stretch1.8.4-3~deb9u2fixed
buster1.10.0-2+deb10u1fixed
bullseye1.10.0-5fixed
bookworm, sid1.11.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tinyproxysourcesqueeze1.8.2-1squeeze2unimportant
tinyproxysource(unstable)1.8.2-2unimportant627503

Notes

Only exploitable through config files, which are under admin control

Search for package or bug name: Reporting problems