CVE-2011-1938

NameCVE-2011-1938
DescriptionStack-based buffer overflow in the socket_connect function in ext/sockets/sockets.c in PHP 5.3.3 through 5.3.6 might allow context-dependent attackers to execute arbitrary code via a long pathname for a UNIX socket.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2399-1
NVD severityhigh

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcelenny5.2.6.dfsg.1-1+lenny14DSA-2399-1
php5sourcesqueeze5.3.3-7+squeeze5DSA-2399-1
php5source(unstable)5.3.6-13low

Notes

[lenny] - php5 <not-affected> (The Lenny version doesn't use memcpy)

Search for package or bug name: Reporting problems