CVE-2011-1944

NameCVE-2011-1944
DescriptionInteger overflow in xpath.c in libxml2 2.6.x through 2.6.32 and 2.7.x through 2.7.8, and libxml 1.8.16 and earlier, allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted XML file that triggers a heap-based buffer overflow when adding a new namespace node, related to handling of XPath expressions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2255-1
NVD severityhigh (attack range: remote)
Debian Bugs628537

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie (security), jessie2.9.1+dfsg1-5+deb8u6fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u2fixed
buster, sid2.9.4+dfsg1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.7.8.dfsg-3high628537
libxml2sourcelenny2.6.32.dfsg-5+lenny4highDSA-2255-1
libxml2sourcesqueeze2.7.8.dfsg-2+squeeze1highDSA-2255-1

Search for package or bug name: Reporting problems