CVE-2011-1959

NameCVE-2011-1959
DescriptionThe snoop_read function in wiretap/snoop.c in Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 does not properly handle certain virtualizable buffers, which allows remote attackers to cause a denial of service (application crash) via a large length value in a snoop file that triggers a stack-based buffer over-read.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2274-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs630159
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie1.12.1+g01b65bf-3fixed
sid1.12.1+g01b65bf-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.6.0-1unimportant630159
wiresharksourcelenny1.0.2-3+lenny14mediumDSA-2274-1
wiresharksourcesqueeze1.2.11-6+squeeze2mediumDSA-2274-1

Notes

Crashes w/o code injection not treated as security issues, see README.Security

Search for package or bug name: Reporting problems