CVE-2011-2023

NameCVE-2011-2023
DescriptionCross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2291-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squirrelmail (PTS)squeeze (security), squeeze2:1.4.21-2fixed
sid, jessie, wheezy2:1.4.23~svn20120406-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squirrelmailsource(unstable)2:1.4.22-1medium
squirrelmailsourcelenny2:1.4.15-4+lenny5mediumDSA-2291-1
squirrelmailsourcesqueeze2:1.4.21-2mediumDSA-2291-1

Search for package or bug name: Reporting problems