CVE-2011-2185

NameCVE-2011-2185
DescriptionFabric before 1.1.0 allows local users to overwrite arbitrary files via a symlink attack on (1) a /tmp/fab.*.tar file or (2) certain other files in the top level of /tmp/.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs629003

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fabric (PTS)stretch1.13.1-2fixed
buster1.14.0-1fixed
bullseye2.5.0-0.3fixed
bookworm, sid2.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fabricsource(unstable)1.1.2-1low629003

Notes

[squeeze] - fabric <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems