CVE-2011-2194

NameCVE-2011-2194
DescriptionInteger overflow in the XSPF playlist parser in VideoLAN VLC media player 0.8.5 through 1.1.9 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors that trigger a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2257-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)stretch3.0.11-0+deb9u1fixed
stretch (security)3.0.11-0+deb9u2fixed
buster, buster (security)3.0.12-0+deb10u1fixed
bookworm, bullseye, sid3.0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcelenny(not affected)
vlcsourcesqueeze1.1.3-1squeeze6DSA-2257-1
vlcsource(unstable)1.1.10-1

Notes

[lenny] - vlc <not-affected> (Vulnerable code not present)
https://repo.or.cz/w/vlc.git/commitdiff/cd929923ff49175a501bb3e9553a683bc42ff61c

Search for package or bug name: Reporting problems