CVE-2011-2204

NameCVE-2011-2204
DescriptionApache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.17, when the MemoryUserDatabase is used, creates log entries containing passwords upon encountering errors in JMX user creation, which allows local users to obtain sensitive information by reading a log file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2401-1
NVD severitylow (attack range: local)
Debian Bugs632882
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)squeeze, squeeze (security)6.0.35-1+squeeze4fixed
squeeze (lts)6.0.41-2+squeeze6fixed
wheezy, wheezy (security)6.0.35-6+deb7u1fixed
stretch, sid, jessie6.0.41-3fixed
tomcat7 (PTS)wheezy, wheezy (security)7.0.28-4+deb7u1fixed
stretch, sid, jessie7.0.56-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat5.5source(unstable)(unfixed)low632882
tomcat6source(unstable)6.0.32-5low632882
tomcat6sourcesqueeze6.0.35-1+squeeze2lowDSA-2401-1
tomcat7source(unstable)7.0.16-3low632882

Notes

[lenny] - tomcat5.5 <no-dsa> (Minor issue)
[lenny] - tomcat6 <no-dsa> (Minor issue)
[squeeze] - tomcat6 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems