CVE-2011-2205

NameCVE-2011-2205
DescriptionProsody before 0.8.1 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs579087

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)stretch0.9.12-2+deb9u2fixed
stretch (security)0.9.12-2+deb9u4fixed
buster, buster (security)0.11.2-1+deb10u2fixed
bullseye, sid0.11.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysource(unstable)0.7.0-1low579087

Notes

[squeeze] - prosody <no-dsa> (Minor issue)
[lenny] - prosody <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems