CVE-2011-2212

NameCVE-2011-2212
DescriptionBuffer overflow in the virtio subsystem in qemu-kvm 0.14.0 and earlier allows privileged guest users to cause a denial of service (guest crash) or gain privileges via a crafted indirect descriptor related to "virtqueue in and out requests."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2282-1
NVD severityhigh (attack range: remote)
Debian Bugs632987
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu-kvm (PTS)squeeze, squeeze (security)0.12.5+dfsg-5+squeeze11fixed
squeeze (lts)0.12.5+dfsg-5+squeeze12fixed
wheezy1.1.2+dfsg-6+deb7u6fixed
wheezy (security)1.1.2+dfsg-6+deb7u8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kvmsource(unstable)(unfixed)high
qemu-kvmsource(unstable)0.14.1+dfsg-3high632987
qemu-kvmsourcesqueeze0.12.5+dfsg-5+squeeze6highDSA-2282-1

Search for package or bug name: Reporting problems