CVE-2011-2216

NameCVE-2011-2216
Descriptionreqresp_parser.c in the SIP channel driver in Asterisk Open Source 1.8.x before 1.8.4.2 does not initialize certain strings, which allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a malformed Contact header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs629130

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2fixed
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcelenny(not affected)
asterisksourcesqueeze(not affected)
asterisksource(unstable)1:1.8.4.2-1629130

Notes

[lenny] - asterisk <not-affected> (Only affects 1.8)
[squeeze] - asterisk <not-affected> (Only affects 1.8)
http://downloads.digium.com/pub/security/AST-2011-007.html

Search for package or bug name: Reporting problems