CVE-2011-2493

NameCVE-2011-2493
DescriptionThe ext4_fill_super function in fs/ext4/super.c in the Linux kernel before 2.6.39 does not properly initialize a certain error-report data structure, which allows local users to cause a denial of service (OOPS) by attempting to mount a crafted ext4 filesystem.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6sourcelenny(not affected)
linux-2.6sourcesqueeze(not affected)
linux-2.6source(unstable)2.6.39-1low

Notes

[squeeze] - linux-2.6 <not-affected> (sbi->s_err-report didn't exist yet)
[lenny] - linux-2.6 <not-affected> (sbi->s_err-report didn't exist yet)

Search for package or bug name: Reporting problems