CVE-2011-2511

NameCVE-2011-2511
DescriptionInteger overflow in libvirt before 0.9.3 allows remote authenticated users to cause a denial of service (libvirtd crash) and possibly execute arbitrary code via a crafted VirDomainGetVcpus RPC call that triggers memory corruption.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2280-1
NVD severitymedium (attack range: remote)
Debian Bugs633630
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)squeeze (security), squeeze0.8.3-5+squeeze5fixed
wheezy, wheezy (security)0.9.12.3-1+deb7u1fixed
jessie, sid1.2.9-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)0.9.2-7medium633630
libvirtsourcelenny0.4.6-10+lenny2mediumDSA-2280-1
libvirtsourcesqueeze0.8.3-5+squeeze2mediumDSA-2280-1

Search for package or bug name: Reporting problems