CVE-2011-2517

NameCVE-2011-2517
DescriptionMultiple buffer overflows in net/wireless/nl80211.c in the Linux kernel before 2.6.39.2 allow local users to gain privileges by leveraging the CAP_NET_ADMIN capability during scan operations with a long SSID value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2303-1
NVD severityhigh (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.39-3unimportant
linux-2.6sourcelenny(not affected)
linux-2.6sourcesqueeze2.6.32-35squeeze1highDSA-2303-1

Notes

[lenny] - linux-2.6 <not-affected> (Vulnerable code not present)
Requires CAP_NET_ADMIn to exploit

Search for package or bug name: Reporting problems