CVE-2011-2519

NameCVE-2011-2519
DescriptionXen in the Linux kernel, when running a guest on a host without hardware assisted paging (HAP), allows guest users to cause a denial of service (invalid pointer dereference and hypervisor crash) via the SAHF instruction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-9fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch (security), stretch4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)(not affected)
xen-3source(unstable)3.2.1-2medium

Notes

Possibly fixed earlier than 3.2.1-2, but that's the version in oldstable, which
was checked to contain http://xenbits.xen.org/hg/xen-3.1-testing.hg/rev/15644
- xen <not-affected> (Only affects older Xen 3 releases)

Search for package or bug name: Reporting problems