CVE-2011-2524

NameCVE-2011-2524
DescriptionDirectory traversal vulnerability in soup-uri.c in SoupServer in libsoup before 2.35.4 allows remote attackers to read arbitrary files via a %2e%2e (encoded dot dot) in a URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2369-1
NVD severitymedium (attack range: remote)
Debian Bugs635837

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsoup2.4 (PTS)wheezy2.38.1-3fixed
jessie, jessie (security)2.48.0-1+deb8u1fixed
stretch, stretch (security)2.56.0-2+deb9u1fixed
buster, sid2.60.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsoup2.4source(unstable)2.34.3-1medium635837
libsoup2.4sourcelenny2.4.1-2+lenny1mediumDSA-2369-1
libsoup2.4sourcesqueeze2.30.2-1+squeeze1mediumDSA-2369-1

Search for package or bug name: Reporting problems