CVE-2011-2532

NameCVE-2011-2532
DescriptionThe json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)buster, buster (security)0.11.2-1+deb10u4fixed
bullseye (security), bullseye0.11.9-2+deb11u2fixed
bookworm, sid0.12.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysource(unstable)0.8.1-1

Notes

[squeeze] - prosody <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems