DescriptionHeap-based buffer overflow in the AVI_ChunkRead_strf function in libavi.c in the AVI demuxer in VideoLAN VLC media player before 1.1.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted AVI media file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs633675
Debian/oldoldstablepackage vlc is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze, squeeze (security)1.1.3-1squeeze6vulnerable
wheezy (security), wheezy2.0.3-5+deb7u2fixed
jessie (security), jessie2.2.0~rc2-2+deb8u1fixed
stretch, sid2.2.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems