CVE-2011-2688

NameCVE-2011-2688
DescriptionSQL injection vulnerability in mysql/mysql-auth.pl in the mod_authnz_external module 3.2.5 and earlier for the Apache HTTP Server allows remote attackers to execute arbitrary SQL commands via the user field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2279-1
NVD severityhigh (attack range: remote)
Debian Bugs633637

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-authnz-external (PTS)wheezy3.2.4-2.1fixed
buster, sid, jessie, stretch3.3.2-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-authnz-externalsource(unstable)3.2.4-2.1medium633637
libapache2-mod-authnz-externalsourcesqueeze3.2.4-2+squeeze1highDSA-2279-1

Search for package or bug name: Reporting problems