CVE-2011-2690

NameCVE-2011-2690
DescriptionBuffer overflow in libpng 1.0.x before 1.0.55, 1.2.x before 1.2.45, 1.4.x before 1.4.8, and 1.5.x before 1.5.4, when used by an application that calls the png_rgb_to_gray function but not the png_set_expand function, allows remote attackers to overwrite memory with an arbitrary amount of data, and possibly have unspecified other impact, via a crafted PNG image.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2287-1
NVD severitymedium (attack range: remote)
Debian Bugs633871
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)squeeze (security), squeeze1.2.44-1+squeeze4fixed
wheezy1.2.49-1fixed
jessie, sid1.2.50-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.2.46-1high633871
libpngsourcelenny1.2.27-2+lenny5mediumDSA-2287-1
libpngsourcesqueeze1.2.44-1+squeeze1mediumDSA-2287-1

Search for package or bug name: Reporting problems