CVE-2011-2696

NameCVE-2011-2696
DescriptionInteger overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2288-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)stretch1.0.27-3fixed
stretch (security)1.0.27-3+deb9u2fixed
buster, buster (security)1.0.28-6+deb10u1fixed
bookworm, sid, bullseye1.0.31-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourcelenny1.0.17-4+lenny3DSA-2288-1
libsndfilesourcesqueeze1.0.21-3+squeeze1DSA-2288-1
libsndfilesource(unstable)1.0.25-1

Search for package or bug name: Reporting problems