CVE-2011-2703

NameCVE-2011-2703
DescriptionMultiple SQL injection vulnerabilities in MapServer before 4.10.7, 5.x before 5.6.7, and 6.x before 6.0.1 allow remote attackers to execute arbitrary SQL commands via vectors related to (1) OGC filter encoding or (2) WMS time support.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2285-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)wheezy6.0.1-3.2+deb7u2fixed
wheezy (security)6.0.1-3.2+deb7u4fixed
jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster, sid7.0.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)6.0.1-1high
mapserversourcelenny5.0.3-3+lenny7highDSA-2285-1
mapserversourcesqueeze5.6.5-2+squeeze2highDSA-2285-1

Search for package or bug name: Reporting problems