CVE-2011-2752

NameCVE-2011-2752
DescriptionCRLF injection vulnerability in SquirrelMail 1.4.21 and earlier allows remote attackers to modify or add preference values via a \n (newline) character, a different vulnerability than CVE-2010-4555.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2291-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squirrelmail (PTS)squeeze, squeeze (security)2:1.4.21-2fixed
sid, jessie, wheezy2:1.4.23~svn20120406-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squirrelmailsource(unstable)2:1.4.22-1low
squirrelmailsourcelenny2:1.4.15-4+lenny5mediumDSA-2291-1
squirrelmailsourcesqueeze2:1.4.21-2mediumDSA-2291-1

Notes

difficult to exploit

Search for package or bug name: Reporting problems