CVE-2011-2770

NameCVE-2011-2770
DescriptionCross-site scripting (XSS) vulnerability in man2html.cgi.c in man2html 1.6, and possibly other version, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to error messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2335-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
man2html (PTS)stretch1.6g-9fixed
buster1.6g-11fixed
bookworm, bullseye, sid1.6g-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
man2htmlsourcelenny1.6f-3+lenny1DSA-2335-1
man2htmlsourcesqueeze1.6f+repack-1+squeeze1DSA-2335-1
man2htmlsource(unstable)1.6g-6

Search for package or bug name: Reporting problems