CVE-2011-2778

NameCVE-2011-2778
DescriptionMultiple heap-based buffer overflows in Tor before 0.2.2.35 allow remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code by (1) establishing a SOCKS connection to SocksPort or (2) leveraging a SOCKS proxy configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2363-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)stretch0.2.9.16-1fixed
stretch (security)0.2.9.15-1fixed
buster, buster (security)0.3.5.16-1fixed
bullseye (security), bullseye0.4.5.10-1~deb11u1fixed
bookworm, sid0.4.6.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcelenny0.2.1.32-1DSA-2363-1
torsourcesqueeze0.2.2.35-1~squeeze+1DSA-2363-1
torsource(unstable)0.2.2.35-1

Search for package or bug name: Reporting problems