CVE-2011-2821

NameCVE-2011-2821
DescriptionDouble free vulnerability in libxml2, as used in Google Chrome before 13.0.782.215, allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted XPath expression.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2394-1
NVD severityhigh (attack range: remote)
Debian Bugs643648
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze, squeeze (security)6.0.472.63~r59945-5+squeeze6fixed
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie43.0.2357.65-1~deb8u1fixed
jessie (security)44.0.2403.89-1~deb8u1fixed
stretch, sid44.0.2403.107-1fixed
libxml2 (PTS)squeeze, squeeze (security)2.7.8.dfsg-2+squeeze8fixed
squeeze (lts)2.7.8.dfsg-2+squeeze12fixed
wheezy2.8.0+dfsg1-7+wheezy2fixed
wheezy (security)2.8.0+dfsg1-7+wheezy4fixed
stretch, jessie2.9.1+dfsg1-5fixed
sid2.9.2+dfsg1-3fixed
webkit (PTS)squeeze1.2.7-0+squeeze2fixed
squeeze (security)1.2.7-0+squeeze1fixed
wheezy1.8.1-3.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)13.0.782.215~r97094-1high
chromium-browsersourcesqueeze(not affected)
libxml2source(unstable)2.7.8.dfsg-5low643648
libxml2sourcelenny2.6.32.dfsg-5+lenny5highDSA-2394-1
libxml2sourcesqueeze2.7.8.dfsg-2+squeeze2highDSA-2394-1
webkitsource(unstable)(not affected)

Notes

- webkit <not-affected> (chromium specific)
[squeeze] - libxml2 <no-dsa> (denial-of-service only issue)

Search for package or bug name: Reporting problems