CVE-2011-3026

NameCVE-2011-3026
DescriptionInteger overflow in libpng, as used in Google Chrome before 17.0.963.56, allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors that trigger an integer truncation.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2410-1
NVD severityhigh (attack range: remote)
Debian Bugs660026
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)squeeze (security), squeeze1.2.44-1+squeeze4fixed
wheezy1.2.49-1fixed
jessie, sid1.2.50-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.2.46-5high660026
libpngsourcesqueeze1.2.44-1+squeeze2highDSA-2410-1

Search for package or bug name: Reporting problems