CVE-2011-3079

NameCVE-2011-3079
DescriptionThe Inter-process Communication (IPC) implementation in Google Chrome before 18.0.1025.168, as used in Mozilla Firefox before 38.0 and other products, does not properly validate messages, which has unspecified impact and attack vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3260-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch62.0.3202.89-1~deb9u1fixed
stretch (security)63.0.3239.84-1~deb9u1fixed
buster62.0.3202.89-1fixed
sid63.0.3239.84-1fixed
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:52.3.0-4~deb7u2fixed
jessie1:45.8.0-3~deb8u1fixed
jessie (security)1:52.3.0-4~deb8u2fixed
stretch (security), stretch1:52.3.0-4~deb9u1fixed
sid1:52.3.0-4fixed
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)18.0.1025.168~r134367-1high
chromium-browsersourcesqueeze(unfixed)end-of-life
icedovesource(unstable)(not affected)
iceweaselsource(unstable)(not affected)
iceweaselsourcejessie31.7.0esr-1~deb8u1highDSA-3260-1
iceweaselsourcewheezy31.7.0esr-1~deb7u1highDSA-3260-1

Notes

- iceweasel <not-affected> (Only affects Firefox on Windows)
- icedove <not-affected> (Only affects Thunderbird on Windows)
https://www.mozilla.org/en-US/security/advisories/mfsa2015-57/

Search for package or bug name: Reporting problems