CVE-2011-3149

NameCVE-2011-3149
DescriptionThe _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2326-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam (PTS)wheezy1.1.3-7.1fixed
jessie1.1.8-3.1+deb8u2fixed
buster, sid, stretch1.1.8-3.6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pamsource(unstable)1.1.3-5low
pamsourcelenny(not affected)
pamsourcesqueeze1.1.1-6.1+squeeze1lowDSA-2326-1

Notes

[lenny] - pam <not-affected> (user_env parsing not yet available)

Search for package or bug name: Reporting problems