CVE-2011-3170

NameCVE-2011-3170
DescriptionThe gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2354-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u6fixed
stretch (security)2.2.1-8+deb9u2fixed
buster2.2.10-6+deb10u4fixed
bullseye2.3.3op2-3+deb11u1fixed
bookworm, sid2.3.3op2-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssourcelenny1.3.8-1+lenny10DSA-2354-1
cupssourcesqueeze1.4.4-7+squeeze1DSA-2354-1
cupssource(unstable)1.5.0-8

Notes

This ID is for an incomplete fix for CVE-2011-2896

Search for package or bug name: Reporting problems