CVE-2011-3208

NameCVE-2011-3208
DescriptionStack-based buffer overflow in the split_wildmats function in nntpd.c in nntpd in Cyrus IMAP Server before 2.3.17 and 2.4.x before 2.4.11 allows remote attackers to execute arbitrary code via a crafted NNTP command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2318-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyrus-imapd-2.4 (PTS)wheezy2.4.16-4+deb7u2fixed
jessie2.4.17+nocaldav-0+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyrus-imapd-2.2source(unstable)2.4.11-1medium
cyrus-imapd-2.2sourcelenny2.2.13-14+lenny5highDSA-2318-1
cyrus-imapd-2.2sourcesqueeze2.2.13-19+squeeze2highDSA-2318-1
cyrus-imapd-2.4source(unstable)2.4.11-1medium
kolab-cyrus-imapdsource(unstable)(unfixed)medium
kolab-cyrus-imapdsourcesqueeze(unfixed)end-of-life

Notes

[squeeze] - kolab-cyrus-imapd <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems