CVE-2011-3211

NameCVE-2011-3211
DescriptionThe server in Bcfg2 1.1.2 and earlier, and 1.2 prerelease, allows remote attackers to execute arbitrary commands via shell metacharacters in data received from a client.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2302-1
NVD severityhigh
Debian Bugs640028

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bcfg2 (PTS)stretch1.4.0~pre2+git141-g6d40dace6358-1fixed
buster1.4.0~pre2+git141-g6d40dace6358-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bcfg2sourcelenny0.9.5.7-1.1+lenny1DSA-2302-1
bcfg2sourcesqueeze1.0.1-3+squeeze1DSA-2302-1
bcfg2source(unstable)1.1.2-2640028

Notes

information as reported by maintainer

Search for package or bug name: Reporting problems