CVE-2011-3323

NameCVE-2011-3323
DescriptionThe OSPFv3 implementation in ospf6d in Quagga before 0.99.19 allows remote attackers to cause a denial of service (out-of-bounds memory access and daemon crash) via a Link State Update message with an invalid IPv6 prefix length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2316-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)jessie0.99.23.1-1+deb8u4fixed
jessie (security)0.99.23.1-1+deb8u5fixed
stretch (security), stretch1.1.1-3+deb9u2fixed
buster, sid1.2.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.19-1medium
quaggasourcelenny0.99.10-1lenny6mediumDSA-2316-1
quaggasourcesqueeze0.99.17-2+squeeze3mediumDSA-2316-1

Search for package or bug name: Reporting problems