CVE-2011-3326

NameCVE-2011-3326
DescriptionThe ospf_flood function in ospf_flood.c in ospfd in Quagga before 0.99.19 allows remote attackers to cause a denial of service (daemon crash) via an invalid Link State Advertisement (LSA) type in an IPv4 Link State Update message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2316-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy0.99.22.4-1+wheezy2fixed
wheezy (security)0.99.22.4-1+wheezy3+deb7u1fixed
jessie (security), jessie0.99.23.1-1+deb8u3fixed
buster, sid, stretch1.1.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.19-1medium
quaggasourcelenny0.99.10-1lenny6mediumDSA-2316-1
quaggasourcesqueeze0.99.17-2+squeeze3mediumDSA-2316-1

Search for package or bug name: Reporting problems