CVE-2011-3327

NameCVE-2011-3327
DescriptionHeap-based buffer overflow in the ecommunity_ecom2str function in bgp_ecommunity.c in bgpd in Quagga before 0.99.19 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code by sending a crafted BGP UPDATE message over IPv4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2316-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)jessie (security), jessie0.99.23.1-1+deb8u5fixed
stretch (security), stretch1.1.1-3+deb9u2fixed
buster, sid1.2.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.19-1high
quaggasourcelenny0.99.10-1lenny6highDSA-2316-1
quaggasourcesqueeze0.99.17-2+squeeze3highDSA-2316-1

Search for package or bug name: Reporting problems