CVE-2011-3348

NameCVE-2011-3348
DescriptionThe mod_proxy_ajp module in the Apache HTTP Server before 2.2.21, when used with mod_proxy_balancer in certain configurations, allows remote attackers to cause a denial of service (temporary "error state" in the backend server) via a malformed HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u16fixed
stretch (security), stretch2.4.25-3+deb9u9fixed
buster, buster (security)2.4.38-3+deb10u3fixed
bullseye, sid2.4.41-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.2.21-1
apache2sourcelenny(not affected)
apache2sourcesqueeze2.2.16-6+squeeze4

Notes

[lenny] - apache2 <not-affected> (introduced in 2.2.12)

Search for package or bug name: Reporting problems