CVE-2011-3358

NameCVE-2011-3358
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2308-1
NVD severitymedium (attack range: remote)
Debian Bugs640297

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mantis (PTS)wheezy1.2.18-1fixed
wheezy (security)1.2.18-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mantissource(unstable)1.2.7-1low640297
mantissourcelenny1.1.6+dfsg-2lenny6mediumDSA-2308-1
mantissourcesqueeze1.1.8+dfsg-10squeeze1mediumDSA-2308-1

Notes

[squeeze] - mantis <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems