CVE-2011-3368

NameCVE-2011-3368
DescriptionThe mod_proxy module in the Apache HTTP Server 1.3.x through 1.3.42, 2.0.x through 2.0.64, and 2.2.x through 2.2.21 does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers via a malformed URI containing an initial @ (at sign) character.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2405-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)squeeze2.2.16-6+squeeze12fixed
squeeze (security)2.2.16-6+squeeze11fixed
squeeze (lts)2.2.16-6+squeeze14fixed
wheezy2.2.22-13+deb7u4fixed
wheezy (security)2.2.22-13+deb7u3fixed
jessie, sid2.4.10-9fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.2.21-2medium
apache2sourcelenny2.2.9-10+lenny12mediumDSA-2405-1
apache2sourcesqueeze2.2.16-6+squeeze6mediumDSA-2405-1

Notes

http://article.gmane.org/gmane.comp.apache.announce/61

Search for package or bug name: Reporting problems