CVE-2011-3378

NameCVE-2011-3378
DescriptionRPM 4.4.x through 4.9.x, probably before 4.9.1.2, allows remote attackers to cause a denial of service (memory corruption) and possibly execute arbitrary code via an rpm package with crafted headers and offsets that are not properly handled when a package is queried or installed, related to (1) the regionSwab function, (2) the headerLoad function, and (3) multiple functions in rpmio/rpmpgp.c.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote)
Debian Bugs645325
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rpm (PTS)squeeze4.8.1-6+squeeze1fixed
squeeze (lts)4.8.1-6+squeeze2fixed
wheezy4.10.0-5+deb7u1fixed
wheezy (security)4.10.0-5+deb7u2fixed
jessie4.11.3-1.1fixed
stretch4.12.0.1+dfsg1-2fixed
sid4.12.0.1+dfsg1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rpmsource(unstable)4.9.1.2-1low645325
rpmsourcesqueeze4.8.1-6+squeeze1high

Notes

[lenny] - rpm <no-dsa> (rpm isn't used a a package manager, very limited attack vector)

Search for package or bug name: Reporting problems