CVE-2011-3585

NameCVE-2011-3585
DescriptionMultiple race conditions in the (1) mount.cifs and (2) umount.cifs programs in Samba 3.6 allow local users to cause a denial of service (mounting outage) via a SIGKILL signal during a time window when the /etc/mtab~ file exists.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cifs-utils (PTS)buster, buster (security)2:6.8-2+deb10u1fixed
bullseye (security), bullseye2:6.11-3.1+deb11u1fixed
bookworm, sid2:7.0-2fixed
samba (PTS)buster, buster (security)2:4.9.5+dfsg-5+deb10u3fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u5fixed
bookworm, sid2:4.17.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cifs-utilssource(unstable)2:4.5-1low
sambasource(unstable)2:3.4.7~dfsg-2low

Notes

cifs-utils was split off from the samba source package with 2:3.4.7~dfsg-2, so marking it as fixed
http://git.samba.org/?p=cifs-utils.git;a=commitdiff;h=810f7e4e0f2dbcbee0294d9b371071cb08268200

Search for package or bug name: Reporting problems