CVE-2011-3597

NameCVE-2011-3597
DescriptionEval injection vulnerability in the Digest module before 1.17 for Perl allows context-dependent attackers to execute arbitrary commands via the new constructor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs644108

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)stretch5.24.1-3+deb9u7fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-6+deb10u1fixed
bullseye5.32.1-4+deb11u2fixed
bullseye (security)5.32.1-4+deb11u1fixed
bookworm, sid5.32.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdigest-perlsourcelenny1.15-2+lenny1
libdigest-perlsourcesqueeze1.16-1+squeeze1
libdigest-perlsource(unstable)1.17-1low644108
perlsourcesqueeze5.10.1-17squeeze3
perlsource(unstable)5.12.4-6low644108

Notes

[lenny] - perl <no-dsa> (Minor issue)
https://github.com/gisle/digest/commit/33800e83550bcad19c4fc593874ec3497841fa1e

Search for package or bug name: Reporting problems