CVE-2011-3639

NameCVE-2011-3639
DescriptionThe mod_proxy module in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x before 2.2.18, when the Revision 1179239 patch is in place, does not properly interact with use of (1) RewriteRule and (2) ProxyPassMatch pattern matches for configuration of a reverse proxy, which allows remote attackers to send requests to intranet servers by using the HTTP/0.9 protocol with a malformed URI containing an initial @ (at sign) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-3368.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2405-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)squeeze2.2.16-6+squeeze12fixed
squeeze (security)2.2.16-6+squeeze11fixed
squeeze (lts)2.2.16-6+squeeze14fixed
wheezy2.2.22-13+deb7u4fixed
wheezy (security)2.2.22-13+deb7u3fixed
jessie, sid2.4.10-9fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.2.18-1medium
apache2sourcelenny2.2.9-10+lenny12mediumDSA-2405-1
apache2sourcesqueeze2.2.16-6+squeeze6mediumDSA-2405-1

Notes

Related to CVE-2011-3368 and CVE-2011-4317 but a different issue

Search for package or bug name: Reporting problems