CVE-2011-3848

NameCVE-2011-3848
DescriptionDirectory traversal vulnerability in Puppet 2.6.x before 2.6.10 and 2.7.x before 2.7.4 allows remote attackers to write X.509 Certificate Signing Request (CSR) to arbitrary locations via (1) a double-encoded key parameter in the URI in 2.7.x, (2) the CN in the Subject of a CSR in 2.6 and 0.25.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2314-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)wheezy2.7.23-1~deb7u3fixed
wheezy (security)2.7.23-1~deb7u4fixed
jessie (security), jessie3.7.2-4+deb8u1fixed
stretch4.8.2-5fixed
buster, sid4.10.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)2.7.3-2medium
puppetsourcesqueeze2.6.2-5+squeeze1mediumDSA-2314-1

Search for package or bug name: Reporting problems