CVE-2011-3940

NameCVE-2011-3940
Descriptionnsvdec.c in libavcodec in FFmpeg 0.7.x before 0.7.12 and 0.8.x before 0.8.11, and in Libav 0.5.x before 0.5.9, 0.6.x before 0.6.6, 0.7.x before 0.7.5, and 0.8.x before 0.8.1, allows remote attackers to cause a denial of service (out-of-bounds read and write) via a crafted NSV file that triggers "use of uninitialized streams."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2471-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze (security), squeeze4:0.5.10-1fixed
squeeze (lts)4:0.5.10-1+deb6u1fixed
sid7:2.6.2-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie, sid6:11.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1medium
ffmpegsourcesqueeze4:0.5.8-1mediumDSA-2471-1
libavsource(unstable)4:0.8.1-1medium

Search for package or bug name: Reporting problems