CVE-2011-3944

NameCVE-2011-3944
DescriptionThe smacker_decode_header_tree function in libavcodec/smacker.c in FFmpeg before 0.10 allows remote attackers to have an unspecified impact via crafted Smacker data.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2855-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage ffmpeg is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1vulnerable
squeeze (lts)4:0.5.10-1+deb6u1vulnerable
sid7:2.7.1-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1+deb8u1fixed
jessie (security)6:11.4-1~deb8u1fixed
stretch, sid6:11.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1medium
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:9.10-1medium
libavsourcewheezy6:0.8.10-1mediumDSA-2855-1

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
Fix in libav: http://git.libav.org/?p=libav.git;a=commitdiff;h=0679cec6e8802643bbe6d5f68ca1110a7d3171da

Search for package or bug name: Reporting problems