CVE-2011-4073

NameCVE-2011-4073
DescriptionUse-after-free vulnerability in the cryptographic helper handler functionality in Openswan 2.3.0 through 2.6.36 allows remote authenticated users to cause a denial of service (pluto IKE daemon crash) via vectors related to the (1) quick_outI1_continue and (2) quick_outI1 functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2374-1
NVD severitymedium (attack range: remote)
Debian Bugs650674

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openswan (PTS)wheezy, wheezy (security)1:2.6.37-3+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openswansource(unstable)1:2.6.37-1low650674
openswansourcelenny1:2.4.12+dfsg-1.3+lenny4mediumDSA-2374-1
openswansourcesqueeze1:2.6.28+dfsg-5+squeeze1mediumDSA-2374-1

Search for package or bug name: Reporting problems