CVE-2011-4075

NameCVE-2011-4075
DescriptionThe masort function in lib/functions.php in phpLDAPadmin 1.2.x before 1.2.2 allows remote attackers to execute arbitrary PHP code via the orderby parameter (aka sortby variable) in a query_engine action to cmd.php, as exploited in the wild in October 2011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2333-1
NVD severityhigh (attack range: remote)
Debian Bugs646754

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpldapadmin (PTS)wheezy1.2.2-5fixed
wheezy (security)1.2.2-5+deb7u1fixed
jessie1.2.2-5.2fixed
buster, sid1.2.2-6.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpldapadminsource(unstable)1.2.0.5-2.1high646754
phpldapadminsourcelenny1.1.0.5-6+lenny2highDSA-2333-1
phpldapadminsourcesqueeze1.2.0.5-2+squeeze1highDSA-2333-1

Search for package or bug name: Reporting problems